Posts Tagged error

Rails – You have already activated spring

Got this error when I was coding for a project


/home/ak/.rvm/gems/ruby-2.2.2@global/gems/bundler-1.10.5/lib/bundler/runtime.rb:34:in `block in setup': You have already activated spring 1.4.0, but your Gemfile requires spring 1.3.4. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)

Just remove the the Gemfile.lock and run again bundle , that will solve the issue.

Advertisements

, , , ,

Leave a comment

When Paperclip uploads are not served in production

You need to do  a file upload and you follow paperclip ( https://github.com/thoughtbot/paperclip ) docs and  upload. All works well in development mode, but in production somehow the uploaded images does not get served and you are wondering why. To rectify this, search for this file <app_path>/config/production.rb and in it search for this statement


config.serve_static_assets = false

Change it to the following


config.serve_static_assets = true

Thats it , the issue must be fixed.

, , , , ,

2 Comments

Strange bundler error

Well, while deploying a Rails app on server I got this error


Bundler::GemNotFound: Could not find minitest-4.7.5.gem for installation
An error occurred while installing minitest (4.7.5), and Bundler cannot continue.
Make sure that `gem install minitest -v '4.7.5'` succeeds before bundling.

this error happened while I was using Ruby 2.1 , to solve this all you need to do is this:


gem update bundler

😉

, , , , ,

Leave a comment